Thrive POS Phone Systems never connecting to an agent

Incident Report for Thrive POS

Resolved

The connection to endpoints have been restored and calls are now routed properly.
Posted Aug 18, 2026 - 13:03 CDT

Investigating

We are currently unable to accept phone calls from Thrive POS and are vendor is investigating. Please send an email request or online to submit a support case or email sales directly.
Posted Aug 18, 2026 - 12:47 CDT
This incident affected: Thrive POS Phone System.